Upgrade the Appeon Workspace for iOS


**IMPORTANT NOTICE**

This notice applies to users that have installed the Appeon Workspace of Appeon for PowerBuilder 2013 R2 or 2015 only, but not 2016 and later, because starting from version 2016, users will need to compile their own workspace for iOS (read more about this change in 2016).

For those who have installed the Appeon Workspace of Appeon for PowerBuilder 2013 R2 or 2015, please make sure you read the following notice carefully and determine whether you will need to upgrade your Appeon Workspace or inform your end users (if you are an ISV) to upgrade theirs.

If you have compiled your own Appeon Workspace or installed it from Apple Store then you can skip this notice as it does not apply to you.

If your Appeon Workspace was installed from outside of the Apple Store, such as over-the-air installation from the Appeon Server or installation via iTunes, then please follow the instructions below to upgrade your Appeon Workspace before September 26, 2018. The reason you must upgrade your Appeon Workspace is that the provisioning profile which is distributed with the Appeon Workspace will expire on September 26, 2018. The Enterprise Provisioning Profiles expire every 12 months according to Apple's policies. For more information please see Managing Expiring Certificates and Provisioning Profiles in the App Distribution Guide - Apple Developer.

You might have already received this expiration notification when launching Appeon Workspace on your device: "The Provisioning Profile "Appeon Enterprise" will expire in ## days". If you tapped "Show Me" you can view more details in the Provisioning settings. If you tapped "Remind Me" you can continue using Appeon Workspace. But once the profile expires Appeon Workspace will not launch any more. You will need to upgrade the Appeon Workspace to refresh the provisioning profile.

Instructions:

Find out the version and build number of your Appeon Workspace in the About screen.

If you are an ISV, get the IPA file of Appeon Workspace from the following link (make sure the build number matches). Then replace the one on your own server (the default location for Appeon Server on .NET is C:\inetpub\wwwroot\appeon\aws). Lastly, inform your end users to upgrade Appeon Workspace from your server.

If you are an end user, install Appeon Workspace directly on your mobile device by clicking the following link.

  • If your build number is 2015 Build 0256 (EN), click here to download the IPA file.
  • If your build number is 2015 Build 0271 (JP/UNIX), click here to download the IPA file.
  • If your build number is 2015 Build 0298, click here to download the IPA file.
  • If your build number is 2015 Build 0328, click here to download the IPA file.
  • If your build number is 2015 Build 0372, click here to download the IPA file.
  • If your version is still 2013 R2, please note that 2013 R2 was end-of-life in 2016. Please upgrade to version 2015 or later.
  • The new IPA file is built with a provisioning profile that will expire on September 18, 2019.

    This is the last time we update and provide the IPA file for version 2015, because version 2015 will be end of life in May 2019. View more about the end-of-life notice for Appeon Web & Mobile 2015.

    Notes:

    For users whose Appeon Workspace cannot launch after September 26, 2018 and those who do not have a chance to upgrade their Appeon Workspace, they can try this workaround: go to Settings -> General -> Profiles, and remove the "Appeon Enterprise" provisioning profile. This workaround may work in some situations.

    On iOS 9 devices, if you encounter the "Unable to Download App" message ("## could not be downloaded at this time"), this is probably because the bundler identifier of the new IPA file does not match with the bundle-identifier property in the .PLIST file. You can check your .PLIST file and make sure bundle-identifier is "com.appeon.mobile.enterprise". After making such change to the .PLIST file the Appeon Workspace should upgrade successfully on iOS 9 devices.